0
Answered

Problem with wall size/texture

Anonymous 5 years ago • updated by Daedalus 4 years ago 5
Hey ive been trying to figure this out but i keep running into walls (no pun intended).

Using my own prefabs for  the walls always generates them at an incorrect size(too small) and any modifications to the size of the prefab do not matter on dungeon generate.

I tried switching the mesh to the same as the ones that come with the package, but this creates a problem with textures (mine wont apply correctly to your mesh's, i have no idea why thats happening, but ive tried exporting my own fbx objects and applying my textures and they fail aswell - im definatly missing something texture wise).

Below is a link to a screenshot of what im talking about:

http://i60.tinypic.com/24ovp7b.jpg

The large dark grey blocks are the packages walls with my texture, the smaller blocks are mine with the same texture applied.   

As you can see the floor pannels are also mis-sized.

Is there somewhere i can edit in the package to accept standard cube sized objects as default size?  

- Marak
+2
Hi Marak, did you have a look at the video tutorials? They explain how to create graphic assets which will just work with Dedalus.

Anyway, Daedalus requires your prefabs to have a MeshFilter in the first object of the hierarchy. Let's say you have a plane that you want to use as a floor tile; the prefab of the plane could have a complex hierarchy with childrens, but it is mandatory that the father (the first object in the hierarchy) has a MeshFilter with a mesh in it, because Daedalus will use that to get the size of the tiles.

Needless to say, if you're using TileMaps, every single tile prefab (walls, columns, floors, etc.) must be squares and must be of the same size. If a floor tile is 6 x 6 Unity's units, a cube used for the wall tile must be the same size.

Let me know if this sheds some light on your problem, otherwise we'll figure out something else to help you.
Thanks for the heads up, i just started watching those (nice vids btw) and i think i spotted my error.

As soon as  i finish resetting up my production machine ill give it a go.

(sorry for the late response, fried a motherboard lol)

- Marak
Yup, just got it in, it was the pivot points, thanks for the heads up :D
Glad you sorted it out! Enjoy using Daedalus.